Home » Windows » Help Desk Processes » [solved] Cisco Anyconnect NAM module gets stuck in the wireless loop and is not able to connect to WIFI

[solved] Cisco Anyconnect NAM module gets stuck in the wireless loop and is not able to connect to WIFI

This is an issue where Cisco Anyconnect fails to connect to the home wireless network and keeps going into a loop by scanning all the networks in the list and is not able to associate any wireless network.

The issue is related to a hidden WIFI defined in the Cisco AnyConnect configurations file for the Cisco AnyConnect NAM module and  can be found the following bug articles recently filed for this issue by Cisco

CSCvt74330. The known affected release is 4.8(3036)

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvt74330/?referring_site=ss&dtid=osscdc000283

Symptom for the Cisco AnyConnect wireless loop.

When admin configured wireless network is hidden and configured for SSO.  The user experience the client not able to switch over to user defined wireless network when the hidden network not found until the user cancel the SSO authentication prompt and manually select the user defined network.

The hidden wireless network could be defined in the configurations file as stated above.

Workaround

You will need to cancel authentication prompt and manually select user define network or  unhide the admin defined hidden WiFi network in the config file found in the the path below:

c:\programdata\cisco\network

Per Cisco support, it is going to be fixed in Cisco AnyConnect stack version 4.9.

Thanks for reading and let me know if this is not accurate.

~best

Hamza Anwar

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*